90 PSI BUT RUNS AMAZING

Discussion in 'Engine' started by lanceblaster69, Oct 9, 2019.

  1. lanceblaster69

    lanceblaster69 Member

    Joined:
    Sep 17, 2019
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    32
    Gender:
    Male
    My blaster has 90 psi of compression but starts first kick every time and runs and idles perfect. 90 psi is way too low for a blaster. Can my Tester be bad? Or should I just rebuild it? When I got it it supposedly had a brand new cylinder which it looked as so but I’m not sure about piston and rings
     
  2. 79 bronco

    79 bronco Moderator & Self Custom Psycho Staff Member

    Joined:
    Apr 9, 2010
    Messages:
    5,414
    Likes Received:
    764
    Trophy Points:
    178
    Gender:
    Male
    Occupation:
    Custom metal fabricator
    Location:
    I don"t know???????
    Yes your tester could be bad! I rebuilt a motor because of a bad tester. After I rebuilt the motor and finished the brake in I did a compression test again and almost craped myself when I had low compression again. Then I realised I had a bad tester.
     
  3. 79 bronco

    79 bronco Moderator & Self Custom Psycho Staff Member

    Joined:
    Apr 9, 2010
    Messages:
    5,414
    Likes Received:
    764
    Trophy Points:
    178
    Gender:
    Male
    Occupation:
    Custom metal fabricator
    Location:
    I don"t know???????
    I have a tester like this now. When I use that adapter thing it gives me a different and lower number. 20191009_123100.jpg
     
  4. lanceblaster69

    lanceblaster69 Member

    Joined:
    Sep 17, 2019
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    32
    Gender:
    Male
    Yes I use the same one.
     

Share This Page