Grease fitting...

Discussion in 'Suspension' started by Robert Zumbro, May 30, 2021.

  1. Robert Zumbro

    Robert Zumbro Member

    Joined:
    Jul 11, 2020
    Messages:
    51
    Likes Received:
    2
    Trophy Points:
    34
    Gender:
    Male
    Occupation:
    Auto detailer
    Location:
    Michigan
    I was wondering if anyone has had issues with the upper a arm grease fitting not wanting to flow good..natuy I thought it was just clogged so I cleaned it out same thing,so I replaced it with a fresh one..same thing didn't wanna flow good or at all..so I removed the bolt and shot grease into the fitting and it worked fine...put the bolt back in and same thing again didn't wanna flow good or at all..any suggestions on this matter??
     
  2. Larry's Shee

    Larry's Shee Active Member Technician

    Joined:
    May 23, 2009
    Messages:
    8,875
    Likes Received:
    968
    Trophy Points:
    149
    Occupation:
    Unemployed carpenter
    Location:
    Ortskaville, MI
    Believe it or not grease actually dries out over time. That might be your problem. Try cleaning it out with brake cleaner.
     
  3. Larry's Shee

    Larry's Shee Active Member Technician

    Joined:
    May 23, 2009
    Messages:
    8,875
    Likes Received:
    968
    Trophy Points:
    149
    Occupation:
    Unemployed carpenter
    Location:
    Ortskaville, MI
  4. Robert Zumbro

    Robert Zumbro Member

    Joined:
    Jul 11, 2020
    Messages:
    51
    Likes Received:
    2
    Trophy Points:
    34
    Gender:
    Male
    Occupation:
    Auto detailer
    Location:
    Michigan
    You talking about cleaning out where the bolt slides through?? Because I can take the bolt out and shoots grease in there fine with the fitting..but as soon as I put the bolt in and try and grease it with the fitting it doesn't wanna grease at all
     

Share This Page