What happened to my piston and why?

Discussion in 'General Support' started by Jewnier, Apr 4, 2021.

  1. Jewnier

    Jewnier New Member

    Joined:
    Apr 4, 2021
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    7
    Gender:
    Male
    IMG_20210403_233619.jpg IMG_20210403_233637.jpg IMG_20210403_234153.jpg IMG_20210403_233653.jpg
    Im a noobie so please advise me if im doing this wrong but i just need a little feed back as to what might have caused this? I just bought it and ran it for about 2 weeks almost daily and just pow she was dead. Carbs a makuni with a pilot of 32.5 and a main of 200 all stock except a fmf spark arrester, and a cheap 10 dollar air filter. Thanks for any feedback. Im in southern cali by the way.
     
    Last edited: Apr 4, 2021
  2. Slydog

    Slydog Active Member Technician

    Joined:
    Nov 3, 2019
    Messages:
    2,043
    Likes Received:
    346
    Trophy Points:
    119
    Gender:
    Male
    Occupation:
    Diesel mech
    Location:
    Florida
    Looks like you may of had a ring snag the exhaust port.
    Piston looks pretty fresh.
    Was it a Chinese aftermarket cylinder kit installed. They are known to not have enough or any chamfering around the ports.or improper install
    How's the big end on that crank?

    Need atleast a 230 main
     
  3. Aldrin Dinero

    Aldrin Dinero Member

    Joined:
    Mar 17, 2021
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    32
    Gender:
    Male
    Same here got her not too long ago been riding it ever since for like 3 weeks stopped for a week then rode it for 2 days and she just shut off on me no compression either im so deppressed
     
  4. Slydog

    Slydog Active Member Technician

    Joined:
    Nov 3, 2019
    Messages:
    2,043
    Likes Received:
    346
    Trophy Points:
    119
    Gender:
    Male
    Occupation:
    Diesel mech
    Location:
    Florida
    Have to get cylinder bored and new piston and gaskets.
    You local machine shop should be able to hook you up.ports must be chamfered.
    Broken rings is common on the cheap egay kits.
    If you have the stock cylinder then bore that as it is a high quality piece.
    You know the saying you get what you pay for.
     
  5. Larry's Shee

    Larry's Shee Active Member

    Joined:
    May 23, 2009
    Messages:
    8,771
    Likes Received:
    938
    Trophy Points:
    149
    Occupation:
    Unemployed carpenter
    Location:
    Ortskaville, MI
    Might have been caused by the ring end gap being to tight. More information on your setup might help. Unfortunately neither of you probably did a leak down test before you took it apart
     

Share This Page