Need help with rear hydro setup

Discussion in 'Brakes' started by Tmorr325, Feb 26, 2018.

  1. Tmorr325

    Tmorr325 Member

    Joined:
    Feb 10, 2016
    Messages:
    121
    Likes Received:
    28
    Trophy Points:
    71
    Gender:
    Male
    Location:
    Pennsylvania
    It’s an 06. 10th digit of the vin is 6. I cut the original brackets off and welded new tabs to fit the new Banshee rear master. The PO had swapped the carrier for an unknown reason.

    12BF488B-F797-4B9F-BFB6-28F69422AEE4.jpeg
     
    Last edited: Mar 8, 2018
  2. Tmorr325

    Tmorr325 Member

    Joined:
    Feb 10, 2016
    Messages:
    121
    Likes Received:
    28
    Trophy Points:
    71
    Gender:
    Male
    Location:
    Pennsylvania
    My title states 2006 and the complete VIN is:

    JY4AG02356C041110

    So yes, It’s definitely an 2006 YFS200 SE

    Also, Still has the original Black/Purple flame plastics.
     
    Last edited: Mar 8, 2018
  3. DUALSTROKE

    DUALSTROKE Giving away free clues Technician

    Joined:
    Mar 2, 2008
    Messages:
    5,269
    Likes Received:
    422
    Trophy Points:
    134
    Location:
    masshole
    Gotcha..Fair enough.. I seen the master cyl mounts and wondered why they were cut off. A banshee master is different than an 03-06 bolt spacing wise. That's why it wouldn't work.
     
  4. Jake642

    Jake642 New Member

    Joined:
    Sep 21, 2017
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    23
    Gender:
    Male
    Hey guys so I have an 02 blaster with a hydro rear brake and Ive had nothing but problems with it since I got the quad first it would only lock up if I pressed hard so I bled the line completely threw and now I have no rear brake
     
  5. blasterbrian

    blasterbrian Member

    Joined:
    Mar 17, 2016
    Messages:
    479
    Likes Received:
    97
    Trophy Points:
    65
    Did you do it properly maybe not building enough pressure, replace all copper washers, look for wear on cable and use dot 4
     
  6. Jake642

    Jake642 New Member

    Joined:
    Sep 21, 2017
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    23
    Gender:
    Male
    I didn't replace the washers I'll do that today and I used dot 4 and I feel like I bled it more than it needed to be just to be safe I had only fluid flowing out but it wasn't spraying out
     
  7. Chadwick

    Chadwick New Member

    Joined:
    Jul 8, 2018
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    18
    Gender:
    Male
    Awk08 I need one of your rear hydraulic kits for my 94 blaster just joined site my email is [email protected]
     
  8. blasterbrian

    blasterbrian Member

    Joined:
    Mar 17, 2016
    Messages:
    479
    Likes Received:
    97
    Trophy Points:
    65
    I'm pretty sure he doesn't make them anymore but I could be wrong sorry for the bad news
     

Share This Page