Lost Spark, Found it!

Discussion in 'Electrical' started by mostdope97, Sep 7, 2021.

  1. mostdope97

    mostdope97 Member

    Joined:
    Jun 8, 2020
    Messages:
    107
    Likes Received:
    13
    Trophy Points:
    54
    Gender:
    Male
    Hey guys, I’ve posted a few times on other spark threads. I lost spark riding and thought it was my coil because I changed the plug and still no spark. Took off the hood and disconnected a white and black wire. Started right up. Only problem is my killswitch and key doesn’t work anymore. Anyone know if I can fix this or what part I might need? At work now and going to look more when I get home!! Thanks in advance.
     
  2. blasterBruce

    blasterBruce Member

    Joined:
    May 13, 2008
    Messages:
    2,372
    Likes Received:
    38
    Trophy Points:
    84
    Gender:
    Male
    Occupation:
    Mechanic/Technician
    Location:
    Griffin Ga
    Check the pdf file for the wiring diagram and trace your wires and find your short to ground- sounds like the issue if you disconnected wires and it sparks
     
  3. Awk08

    Awk08 Administrator Staff Member Technician

    Joined:
    Jan 30, 2009
    Messages:
    24,424
    Likes Received:
    2,282
    Trophy Points:
    175
    Occupation:
    Electrician/Contractor
    Location:
    Pa.
    Plug the key and kill switches back in one at a time,
    whichever allows it to start is good, the one that prevents starting is bad, leave it unplugged or replace it
     
    piezzi likes this.

Share This Page