Blaster jetting, need some help!

Discussion in 'Engine' started by PurplePants, Jun 1, 2019.

  1. PurplePants

    PurplePants New Member

    Joined:
    Oct 25, 2018
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    17
    Gender:
    Male
    Hey guys i'm new to this forum and need some help with my Blaster. It is mostly stock, when i bought it the carb was very gummed up so I replaced it with a niche industries one off of amazon. It has Boyesen power reeds in it and the guy before me drilled six holes in the air box lid. I just put a full Bills exhaust system on it and i cant figure out the jetting. I had the stock pilot jet in it to start off with and then i tried a 35 and it seemed to run fine but was fouling plugs (too rich i guess), now i have all the stock jets in it and it is driving fine but the idle hangs like crazy and it is fouling a plug almost every ride, any ideas? Thanks!
     
  2. Larry's Shee

    Larry's Shee Active Member

    Joined:
    May 23, 2009
    Messages:
    8,036
    Likes Received:
    731
    Trophy Points:
    149
    Occupation:
    Unemployed carpenter
    Location:
    Ortskaville, MI
    Have you checked trans level? Does it smoke a lot?
    Have you ever done a leak down test?
    Exhaust has to be sealed 100% at flange to cylinder and flange to pipe.

    Good possibility that the carb is junk, just like everything else Niche sells.
     
  3. Larry's Shee

    Larry's Shee Active Member

    Joined:
    May 23, 2009
    Messages:
    8,036
    Likes Received:
    731
    Trophy Points:
    149
    Occupation:
    Unemployed carpenter
    Location:
    Ortskaville, MI
  4. Larry's Shee

    Larry's Shee Active Member

    Joined:
    May 23, 2009
    Messages:
    8,036
    Likes Received:
    731
    Trophy Points:
    149
    Occupation:
    Unemployed carpenter
    Location:
    Ortskaville, MI
    What size main jet do you have in now?
     
  5. PurplePants

    PurplePants New Member

    Joined:
    Oct 25, 2018
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    17
    Gender:
    Male
    I actually just threw in a 260 and put in a BR8ES and shes running like a beauty. It had a BR9ES in from the previous owner so thats what i thought was the right one. Also I've actually had good luck with Niche Industries so far, my brother has rebuilt a few 400ex's and has used some of their stuff. Do you mean the oil in the transmission level? I've also noticed that the pipe is leaking just a tad from the flange so i'll try fix it, i did'nt know that made a difference.
     
  6. Larry's Shee

    Larry's Shee Active Member

    Joined:
    May 23, 2009
    Messages:
    8,036
    Likes Received:
    731
    Trophy Points:
    149
    Occupation:
    Unemployed carpenter
    Location:
    Ortskaville, MI
    That's why, a nine is a colder plug. Oil sight glass on clutch cover. Thought maybe was sucking trans oil fouling the plug.
     

Share This Page