Blaster is Backfiring

Discussion in 'Engine' started by recruiter101st, Apr 29, 2011.

  1. recruiter101st

    recruiter101st New Member

    Joined:
    Apr 24, 2011
    Messages:
    129
    Likes Received:
    0
    Trophy Points:
    0
    Occupation:
    US Army
    Location:
    Champaign, il
    Ok here is what its doing. Was running fine stock. Now that I have added a FMF Silencer, 4 Degree advance, it keeps backfiring and Not running real well, I am running stock pilot jet, 3rd clip on needle and running a 270 main.
    I am not sure what is going on what can cause this. Please help
  2. mmajay

    mmajay 800 V Twin

    Joined:
    Aug 6, 2010
    Messages:
    1,636
    Likes Received:
    17
    Trophy Points:
    0
    Occupation:
    Machinist/welder
    Location:
    Busco Beach NC/ Goldsboro
    I would go to stock timeing to see if it quits backfireing first. Allways install a new plug as well to rule that out as well and i dont care if it is new allready i still change it to rule that out 100%.
  3. recruiter101st

    recruiter101st New Member

    Joined:
    Apr 24, 2011
    Messages:
    129
    Likes Received:
    0
    Trophy Points:
    0
    Occupation:
    US Army
    Location:
    Champaign, il
    I will change the timing when I get a chance, But the idle is really rough on it and when I grap the idle adjustment on the THORS it dies.
  4. mmajay

    mmajay 800 V Twin

    Joined:
    Aug 6, 2010
    Messages:
    1,636
    Likes Received:
    17
    Trophy Points:
    0
    Occupation:
    Machinist/welder
    Location:
    Busco Beach NC/ Goldsboro
    Eliminate the tors would be another thing to do to help out and eliminate possible problems. Sounds like you need to get rid of the tors and really clean that carb.
  5. yzrider

    yzrider Member

    Joined:
    Apr 12, 2009
    Messages:
    5,097
    Likes Received:
    42
    Trophy Points:
    48
    Occupation:
    job you ask...... i wish!
    Location:
    northwest Indiana
    check plug, i'v even over oiled my air filter and it ran weird once, remove tors, report back
  6. recruiter101st

    recruiter101st New Member

    Joined:
    Apr 24, 2011
    Messages:
    129
    Likes Received:
    0
    Trophy Points:
    0
    Occupation:
    US Army
    Location:
    Champaign, il
    Im lost, Some people are saying exhaust leak? Not sure what the heck is going, Stinks that this weekend is great weather,
  7. 05blasterkid

    05blasterkid New Member

    Joined:
    Apr 24, 2010
    Messages:
    459
    Likes Received:
    2
    Trophy Points:
    0
    Location:
    Corning, NY
    I'm not an expert but it could be jetting?! You might be running lean with that 270 main. Everyone I know with a fmf is running a 290. Idk if the timing advance could affect anything but I think your pretty lean. On 4 strokes when they backfire it's wither jetting or valves. But 2 strokes don't have valves so I would bet it's your carb.
  8. recruiter101st

    recruiter101st New Member

    Joined:
    Apr 24, 2011
    Messages:
    129
    Likes Received:
    0
    Trophy Points:
    0
    Occupation:
    US Army
    Location:
    Champaign, il
    Im Running a uni Filter with airbox removed, 4 degrees advance, and FMF Silencer, Stock Head pipe(for now) You guys think Im running lean? Its backfiring even in middle of throttle. Running like poo even at idle. keep the ideas coming guys
  9. super noober

    super noober Can't Stop, Won't Stop!

    Joined:
    Feb 17, 2009
    Messages:
    7,774
    Likes Received:
    69
    Trophy Points:
    0
    Occupation:
    Nothing worth bragging about
    Location:
    upstate ny
    how did u do the timing mod? did u get a adjustable plate or just do thr
    diy?
  10. recruiter101st

    recruiter101st New Member

    Joined:
    Apr 24, 2011
    Messages:
    129
    Likes Received:
    0
    Trophy Points:
    0
    Occupation:
    US Army
    Location:
    Champaign, il
    I did the DIY version
  11. 99LRDblaster

    99LRDblaster New Member

    Joined:
    Jan 25, 2011
    Messages:
    2,481
    Likes Received:
    17
    Trophy Points:
    0
    Location:
    Delphos/Columbus, Ohio
    Did you rotate the stator plate CLOCKWISE and not counterclockwise? It should be clockwise. Also, make sure the flywheel is on all the way. I would also suggest bumping up to a 290 as well just to play it safe. First things first though, check the timing......make sure you did it right....if you did it right and your quad is somehow different from all other Blasters, put it back to the stock timing.

    EDIT: Nevermind I thought you were running the FMF pipe, not the stock pipe.
    Last edited: Apr 29, 2011
  12. recruiter101st

    recruiter101st New Member

    Joined:
    Apr 24, 2011
    Messages:
    129
    Likes Received:
    0
    Trophy Points:
    0
    Occupation:
    US Army
    Location:
    Champaign, il
    Yes rotated Clockwise, Maybe just a tad over 4 however, May just put it back to stock and see what that does.
  13. 99LRDblaster

    99LRDblaster New Member

    Joined:
    Jan 25, 2011
    Messages:
    2,481
    Likes Received:
    17
    Trophy Points:
    0
    Location:
    Delphos/Columbus, Ohio
    Try that first and see how it runs. Make sure to inspect the key and see what shape it's in.
  14. recruiter101st

    recruiter101st New Member

    Joined:
    Apr 24, 2011
    Messages:
    129
    Likes Received:
    0
    Trophy Points:
    0
    Occupation:
    US Army
    Location:
    Champaign, il
    Will check it all out in the morning. Could a fouled plug cause this? What about installing the new FMF Silencer? maybe an exhaust leak causing it?
  15. 99LRDblaster

    99LRDblaster New Member

    Joined:
    Jan 25, 2011
    Messages:
    2,481
    Likes Received:
    17
    Trophy Points:
    0
    Location:
    Delphos/Columbus, Ohio
    A fouled plug can cause a misfire, but if this has just suddenly occurred after a modification, it may be due to the modification and/or jetting.
  16. 99LRDblaster

    99LRDblaster New Member

    Joined:
    Jan 25, 2011
    Messages:
    2,481
    Likes Received:
    17
    Trophy Points:
    0
    Location:
    Delphos/Columbus, Ohio
    I made the edit above, but you won't need a 290 main like I said previously. I though you said you had an FMF pipe and rereading it you have the stock pipe with FMF silencer. 270 should be more than a enough to START with.....probably too rich.
  17. recruiter101st

    recruiter101st New Member

    Joined:
    Apr 24, 2011
    Messages:
    129
    Likes Received:
    0
    Trophy Points:
    0
    Occupation:
    US Army
    Location:
    Champaign, il
    It ran Fine a week ago bone stock, All I have done since then is added a FMF Silencer and 4 degree advance with an open air box and Uni filter. I just dont understand why after these mods Its now running like crap. can the Thors have anything to do with this?
  18. blasterracer817

    blasterracer817 New Member

    Joined:
    Jul 4, 2009
    Messages:
    971
    Likes Received:
    5
    Trophy Points:
    18
    Occupation:
    nothin, hope to start a performance shop this summ
    Location:
    caledonia mn
    I'm gonna guess if your jetting is on then it is your flywheel key, advancing only 4 degrees, or even nincompooping if you were to accidently wouldnt cause a backfire, tors shouldnt really be an issue, I have only heard of a few tors systems actually failing, the rest are taken off to add a bigger carb, im guessing its a sheard flywheel key, pull your flywheel and look at the key lol
  19. recruiter101st

    recruiter101st New Member

    Joined:
    Apr 24, 2011
    Messages:
    129
    Likes Received:
    0
    Trophy Points:
    0
    Occupation:
    US Army
    Location:
    Champaign, il
    I would love to pull that flywheel right now! But the quad is at my parents which is 45 min away. I am heading to their house tomorrow. So the key could be screwed up? and still atleast somewhat run? I mean today i did ride it, it just ran Sh$$y
  20. 99LRDblaster

    99LRDblaster New Member

    Joined:
    Jan 25, 2011
    Messages:
    2,481
    Likes Received:
    17
    Trophy Points:
    0
    Location:
    Delphos/Columbus, Ohio
    Like I said, just zip it off check the key and see for yourself. That's about the only way you will be able to tell. You will probably be taking the timing back to stock to double check anyways, so you will most likely get your answer regardless.

Share This Page